PHP7MAR:協助找出哪些程式需要由 PHP5 升級到 PHP7 的工具

程式要將 PHP5 升級到 PHP7,大多數都好解決,主要是 DB 若還是傳統 MySQL Library (mysql_*),沒有轉換成 PDO 就會比較麻煩

這套程式可以幫忙掃出哪些還是舊的 PHP5 的寫法,需要轉換成 PHP7 的

PHP7MAR:協助找出哪些 PHP5 程式 需要升級到 PHP7 的工具

先寫 Debian Linux 於套件有需要注意的部份:

  • php7.0-bcmath # 若有用到 bcxxx(),這個需要額外安裝
  • php7.0-opcache # apc 在 php7 都使用 opcache

MAR (Migration Assistant Report) 這套程式需要用 PHP 7 執行,可以幫忙掃出此目錄下面,哪些程式「建議」需要修正升級

註:「建議」的意思是,有些可能不需要立即修正

PHP7MAR 的程式安裝與操作

  1. git clone https://github.com/Alexia/php7mar
  2. cd php7mar
  3. php mar.php -f=/var/www/website
  4. vim reports/2017...website.md # report 裡面很清楚

關於 Tsung

對新奇的事物都很有興趣, 喜歡簡單的東西, 過簡單的生活.
本篇發表於 Programming 並標籤為 , , , , , , 。將永久鏈結加入書籤。

發表迴響