MacOS 如何安裝舊版的 Xcode - 2019

安裝新版的 Xcode 造成某些異常事件,想要安裝舊版的 Xcode,並且讓新、舊版的 Xcode 同時存在,要怎麼做呢?

  • 註:目前 Xcode 最新版為 10.1

MacOS 如何安裝舊版的 Xcode

Mac 要同時安裝多個版本的 Xcode,記得硬碟要先多清出一點空間(隨便一個 Xcode 都要 4G 以上)。

Apple 官方網站就可以抓到所有版本的資料,只是需要登入開發者的帳號(不用付費都可以下載),下載網頁如下:

  1. Download - Apple Developer # 往下點有「See more downloads」
  2. More Downloads for Apple Developers # 此為 more 的連結
  3. 找到 Xcode 9.4.1 Jun 13,2018 # 點選即可下載
  4. 下載取得的 Xcode_9.4.1.xpi 檔案,點擊兩下會自動解壓縮,產生一個 Xcode 的檔案
  5. 重新命名 Xcode,改名為 Xcode-9.4.1,再將此檔案搬到 「應用程式」 裡面去
  6. 打開「應用程式」,找到 Xcode-9.4.1,點擊執行,就會打開 Xcode 9.4.1 版,原本的 Xcode 還是 10.1 版
    • 下面兩個命令是不想手動切換,想直接 CLI 切換用的
      • $ sudo xcode-select -s /Applications/Xcode-9.4.1.app/Contents/Developer
      • $ xcode-select -p /Applications/Xcode-9.4.1.app/Contents/Developer
  7. 移除只要將「應用程式」的 Xcode-9.4.1 和 下載的 Xcode_9.4.1.xpi 拖到垃圾桶就好了

註:經過此次測試,Xcode 9.x 版 和 10.1 版都可以分別執行,但是遇到 iPhone iOS 12,9.x 版直接說不支援,還是得要開 10.1 版才能用... XD

相關網頁

關於「Tsung」

對新奇的事物都很有興趣, 喜歡簡單的東西, 過簡單的生活.
分類: Programming,標籤: , , , , , 。這篇內容的永久連結

發表迴響

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料