Git 低於 2.7.1 的安全性問題修正

Git 於 2016/3/17 有發現漏洞,而且問題不小,詳可見:Remote Code Execution in all git versions (client + server) < 2.7.1: CVE-2016-2324, CVE-2016‑2315

Git 低於 2.7.1 的安全性問題修正

這個漏洞會影響的情況是:透過 git clone 抓取遠端的有問題的 repository,有可能導致 Git Client 或 Server 執行任意的程式碼。

  • 註:手邊若有用任何 GUI 套件,那些套件也都需要更新。

Git 2.7.1 之前的版本都有此問題,不過如果套件本身有更新修正的話,就不用看版本。

  • 註:Debian jessie 的 Git 是 2.1.4 版,但有修正此問題

Debian Linux 的套件如下:(Debian 要記得 apt-get upgrade 更新,就會是下述版本)

  • CVE-2016-2315
    • wheezy (security) 1:1.7.10.4-1+wheezy3 (wheezy 此版本就是安全的)
    • jessie (security) 1:2.1.4-2.1+deb8u2 (jessie 此版本就是安全的)
  • CVE-2016-2324
    • wheezy (security) 1:1.7.10.4-1+wheezy3 (wheezy 此版本就是安全的)
    • jessie (security) 1:2.1.4-2.1+deb8u2 (jessie 此版本就是安全的)

關於 Tsung

對新奇的事物都很有興趣, 喜歡簡單的東西, 過簡單的生活.
本篇發表於 News 並標籤為 , , , , 。將永久鏈結加入書籤。

發表迴響

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料