PHP PECL 升級遇到 unsupported protocol 修復

PHP PECL 升級時,遇到下述錯誤訊息:

  • $ sudo pecl upgrade

    pear.php.net is using a unsupported protocol - This should never happen.
    upgrade failed

要如何修復呢?

PHP PECL 升級遇到 unsupported protocol 修復

PHP PECL 升級遇到 unsupported protocol 等等的問題,通常就是需要 update-channels,再來執行 upgrade 即可。

註:通常會需要先做 pear 的 channels update、upgrade

  1. pear update-channels # 與 pecl update-channels 都會一起做
  2. pecl update-channels # 多做一次看看
  3. pear upgrade # 通常這個做下去,pecl upgrade 都一起做完了
  4. pecl upgrade # 這個應該是多做的
  5. pecl list # 檢查看看版本是否都更新了

相關網頁

關於「Tsung」

對新奇的事物都很有興趣, 喜歡簡單的東西, 過簡單的生活.
分類: My_Note-Unix,標籤: , , , , 。這篇內容的永久連結

發表迴響

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料