APT 攻擊(Advanced Persistent Threats) 真實案例模擬影片

這部影片看來是 Trend Micro 的行銷影片, 不過拍的很不錯~ 短短的5分鐘, 有空可以看看~

閱讀全文〈APT 攻擊(Advanced Persistent Threats) 真實案例模擬影片〉

於 Debian Wheezy 使用 APT 安裝 Percona MySQL Server - 2013

於 Debian squeeze (stable) 安裝 Percona MySQL Server 只要照此篇: 於 Ubuntu、Debian 安裝 MySQL Percona 就可以完成.

但是若是從一開始版本就是用 Wheezy (Testing), Percona 官方支援(Percona Software) 還沒 Support, 就會遇到一些問題.

註: 此篇於 Percona MySQL 出 Wheezy DEB Package 後, 就只要照上面的連結做就可以了, 以下是直接裝 Debian Testing 時, Percona 遇到尚未出版本, 然後有遇到套件相依有問題的狀況, 提供可能的解決方式.

Debian Squeeze 和 Wheezy 在安裝 Percona 會遇到的問題, 最主要是差在 libssl (squeeze: libssl0.9.8, wheezy: libssl1.0.0).

直接使用 APT 安裝, 會遇到下述問題:

percona-server-server : 相依關係: percona-server-server-5.5 但它卻將不會被安裝
E: 無法修正問題,您保留 (hold) 了損毀的套件。

percona-server-server-5.5 : 相依關係: libssl0.9.8 (>= 0.9.8m-1) 但它卻無法安裝
E: 無法修正問題,您保留 (hold) 了損毀的套件。

不理 libssl, 直接強迫安裝的話(下載 deb 使用 dpkg --ignore-depends, 或 apt-get -f 強制安裝), 其中相依的套件都裝好後, 啟動 MySQL 會遇到下述問題:

mysql: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

閱讀全文〈於 Debian Wheezy 使用 APT 安裝 Percona MySQL Server - 2013〉